No longer warn for console.log's (v1.0.6)

This commit is contained in:
Chase 2023-01-31 15:27:48 -06:00
parent 83126b66af
commit 3c2a09d3ef
Signed by: chase
GPG Key ID: 9EC29E797878008C
4 changed files with 25 additions and 16 deletions

View File

@ -10,5 +10,12 @@ charset = utf-8
trim_trailing_whitespace = true
insert_final_newline = true
[*.{yml,yaml}]
indent_size = 2
[*.json]
insert_final_newline = false
[{Makefile,**.mk}]
# Use tabs for indentation (Makefiles require tabs)
indent_style = tab

9
Makefile Normal file
View File

@ -0,0 +1,9 @@
.DEFAULT_GOAL:=help
.PHONY: help
help:
@grep -E '^[a-zA-Z_-]+:.*?## .*$$' $(MAKEFILE_LIST) | sort | awk 'BEGIN {FS = ":.*?## "}; {printf "\033[36m%-30s\033[0m %s\n", $$1, $$2}'
update: ## Bumps installed deps.
@npx npm-check-updates -u && npm install

View File

@ -53,13 +53,6 @@ module.exports = {
}
],
"no-console": `off`,
"no-restricted-syntax": [
`warn`,
{
selector: `CallExpression[callee.object.name='console'][callee.property.name=/^(log)$/]`,
message: `Do not console.log if it's not necessary. If it is necessary, feel free to disable this rule.`
}
],
"brace-style": [
`error`,
`allman`,

View File

@ -1,6 +1,6 @@
{
"name": "eslint-config-chase",
"version": "1.0.5",
"version": "1.0.6",
"description": "Personal ESLint Config",
"main": "index.js",
"scripts": {
@ -17,19 +17,19 @@
"url": "https://github.com/chxseh/eslint-config.git"
},
"dependencies": {
"eslint-plugin-import": "^2.26.0",
"eslint-plugin-import": "^2.27.5",
"eslint-config-airbnb-base": "^15.0.0",
"eslint-plugin-jsdoc": "^39.3.6",
"eslint-plugin-unicorn": "^45.0.0"
"eslint-plugin-jsdoc": "^39.7.5",
"eslint-plugin-unicorn": "^45.0.2"
},
"peerDependencies": {
"eslint": "^8.23.0",
"eslint-plugin-import": "^2.26.0",
"eslint": "^8.33.0",
"eslint-plugin-import": "^2.27.5",
"eslint-config-airbnb-base": "^15.0.0",
"eslint-plugin-jsdoc": "^39.3.6",
"eslint-plugin-unicorn": "^45.0.0"
"eslint-plugin-jsdoc": "^39.7.5",
"eslint-plugin-unicorn": "^45.0.2"
},
"devDependencies": {
"eslint": "^8.23.0"
"eslint": "^8.33.0"
}
}